Начать новую тему

Свои скрипты выдают Security error

Решили внедрить дополнительную функциональность в виде скриптов.

Скрипты загрузили локально в папку "Пользовательские файлы".

Часть скриптов отрабатывает нормально. Часть выдает ошибку "SecurityError", которая свойственна внешним скриптам, а локально таких проблем быть не должно.

Из-за чего могла появится такая ошибка?


http://master-panda.ru/editor


Uncaught SecurityError: Failed to execute 'getImageData' on 'CanvasRenderingContext2D': The canvas has been tainted by cross-origin data.(anonymous function) @ imageProcess.js:99(anonymous function) @ fabric.min.js:6n.onload @ fabric.min.js:1



Здравствуйте.


К сожалению, в рамках поддержки Мерчиума мы не оказываем поддержку сторонних скриптов. Приносим извинения за неудобства.


Спасибо.

Возможно, я не совсем корректно задал вопрос, хотелось узнать нет ли, каких-то принципиальных ограничений Мерчиума, которые не позволяют использовать свои скрипты. Если проблема в самом скрипте, то, конечно, мы сами будем ее решать.

 

Таких ограничений в явном виде в Мерчиуме нет: мы не блокируем подключаемые скрипты. Возможно, проблема связана с конфликтом между скриптами Мерчиума и используемым кодом. 


Спасибо.


Войдите, чтобы опубликовать свой комментарий